A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 21:18 CDT
Identified
The issue has been identified and we are working to resolve this issue for customers as soon as possible
Posted Jun 04, 2026 - 19:07 CDT
Update
We are continuing to investigate the issue
Posted Jun 04, 2026 - 18:11 CDT
Investigating
We are aware of some users experiencing issues with login in via mobile for both Android and iOS systems. The web app is working as expected. The team is investigating
Posted Jun 04, 2026 - 16:05 CDT
This incident affected: Web Dashboard & Mobile App.