All systems are back to operational status. We will continue monitor the situation.
Posted Oct 20, 2025 - 16:04 CDT
Update
Threat Warnings are operational and we are continuing to monitor the situation for Imports
Posted Oct 20, 2025 - 16:00 CDT
Monitoring
We are continuing to see delays in sending Threat Warnings
Posted Oct 20, 2025 - 15:08 CDT
Update
There remain issues related to SFTP (AWS Transfer Family Service) that are still causing import issues.
Posted Oct 20, 2025 - 13:51 CDT
Update
We are experiencing delayed notifications due to downstream providers. FTP Import performance is still degraded for both environments
Posted Oct 20, 2025 - 12:56 CDT
Update
FTP Imports are not processing in either environment
Posted Oct 20, 2025 - 10:24 CDT
Update
FTP imports are operational in the NA2 production environment. They are not processing in the NA1 production environment.
Posted Oct 20, 2025 - 07:55 CDT
Update
FTP imports are not currently processing. Employee Safety Monitoring is down.
Posted Oct 20, 2025 - 07:34 CDT
Update
Notification sends and threat warnings are operational.
FTP imports are not currently processing.
Posted Oct 20, 2025 - 06:50 CDT
Update
Updated impacted components
Posted Oct 20, 2025 - 05:05 CDT
Update
Notification sends are processing. Recovery in progress.
Posted Oct 20, 2025 - 05:05 CDT
Identified
AWS services are recovering and we are mitigating impact where possible. The service responsible for notification sends is degraded, delaying notifications, threat warnings, and incident response tasks.
Posted Oct 20, 2025 - 04:46 CDT
This incident affected: Notifications, Global Intelligence, Employee Safety Sessions & Panic Button, and Import and User Provisioning.